Commit f6a34458 by Łukasz Nowak

setup: Allow to easily install test requirements

parent 594c8231
......@@ -20,6 +20,12 @@
from setuptools import setup, find_packages
import versioneer
tests_require = [
'capturer',
'urllib3 >= 1.18', # https://github.com/urllib3/urllib3/issues/258
'ipaddress',
]
setup(
name='kedifa',
version=versioneer.get_version(),
......@@ -49,11 +55,8 @@ setup(
# is not working in some cases, but fortunately KeDiFa is
# used in places with pinned versions
],
tests_require=[
'capturer',
'urllib3 >= 1.18', # https://github.com/urllib3/urllib3/issues/258
'ipaddress',
],
tests_require=tests_require,
extras_require={'test': tests_require},
zip_safe=True,
entry_points={
'console_scripts': [
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or sign in to comment