• David Leonard's avatar
    UBUNTU: [Debian] fix linux_tools when cross-compiling · f6e260d3
    David Leonard authored
    Fixed invocation of dh_shlibdeps when cross-compiling with
    do_linux_tools=true.
    Without being told where to find the crossdev libs, dh_shlibdeps
    will emit these warnings and fail the linux-tools package:
    
      Debug: binary-acm7xxx
      ...
      dh_shlibdeps -plinux-headers-4.4.0-15-generic
      arm-linux-gnueabihf-objdump: .../asn1_compiler: File format not recognized
      arm-linux-gnueabihf-objdump: .../extract-cert: File format not recognized
      ...
    
    For example:
    
    archtriple=arm-linux-gnueabihf
             flavour=generic
             dpkg-architecture -t $archtriple -c fakeroot \
                    debian/rules \
                    binary-$flavour binary-perarch \
                    AUTOBUILD=true \
                    abi_suffix= \
                    do_linux_tools=true \
                    do_tools=true \
                    do_tools_usbip=false \
                    do_tools_cpupower=false \
                    do_tools_perf=true \
                    do_tools_x86=false
    Signed-off-by: default avatarDavid Leonard <david.leonard@opengear.com>
    Signed-off-by: default avatarTim Gardner <tim.gardner@canonical.com>
    f6e260d3
2-binary-arch.mk 28 KB