Commit 8af78fc5 authored by Kirill Smelkov's avatar Kirill Smelkov

pyx.build: v↑ setuptools_dso (1.2 -> 1.4)

Projects that use pyx.build (ex. wendelin.core) need recent
setuptools_dso fixes:

https://github.com/mdavidsaver/setuptools_dso/issues/5
https://github.com/mdavidsaver/setuptools_dso/commit/67d717a6
https://github.com/mdavidsaver/setuptools_dso/commit/e40f5883
https://github.com/mdavidsaver/setuptools_dso/commit/40b492ab

Increase setuptools_dso version in pygolang's build requirement for
uniformity as well.
parent 64765688
[build-system]
requires = ["setuptools", "wheel", "setuptools_dso >= 1.2", "cython", "gevent"]
requires = ["setuptools", "wheel", "setuptools_dso >= 1.4", "cython", "gevent"]
# pygolang | pythonic package setup
# Copyright (C) 2018-2019 Nexedi SA and Contributors.
# Copyright (C) 2018-2020 Nexedi SA and Contributors.
# Kirill Smelkov <kirr@nexedi.com>
#
# This program is free software: you can Use, Study, Modify and Redistribute
......@@ -156,7 +156,7 @@ class develop(XInstallGPython, _develop):
# requirements of packages under "golang." namespace
R = {
'cmd.pybench': {'pytest'},
'pyx.build': {'setuptools', 'wheel', 'cython', 'setuptools_dso >= 1.2'},
'pyx.build': {'setuptools', 'wheel', 'cython', 'setuptools_dso >= 1.4'},
'x.perf.benchlib': {'numpy'},
}
# TODO generate `a.b -> a`, e.g. x.perf = join(x.perf.*); x = join(x.*)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment