Commit 99cf2adc authored by Julien Muchembled's avatar Julien Muchembled

For the moment, only OpenVPN 2.4.* is supported

parent 63a4702c
...@@ -54,7 +54,7 @@ Requirements ...@@ -54,7 +54,7 @@ Requirements
- Python 2.7 - Python 2.7
- OpenSSL binary and development libraries - OpenSSL binary and development libraries
- OpenVPN >= 2.4 - OpenVPN 2.4.*
- Babel_ (with Nexedi patches) - Babel_ (with Nexedi patches)
- geoip2: `python library`_ and `country lite database`_ (optional) - geoip2: `python library`_ and `country lite database`_ (optional)
- python-miniupnpc for UPnP support (optional) - python-miniupnpc for UPnP support (optional)
......
...@@ -8,7 +8,7 @@ X-Python-Version: >= 2.7 ...@@ -8,7 +8,7 @@ X-Python-Version: >= 2.7
Package: re6stnet Package: re6stnet
Architecture: all Architecture: all
Depends: ${misc:Depends}, ${python:Depends}, python-pkg-resources, python-openssl (>= 0.13), openvpn (>= 2.4), babeld (= 1.9.1+hmac-nxd2), iproute2 | iproute, openssl Depends: ${misc:Depends}, ${python:Depends}, python-pkg-resources, python-openssl (>= 0.13), openvpn (>= 2.4), openpvn (<< 2.5~), babeld (= 1.9.1+hmac-nxd2), iproute2 | iproute, openssl
Recommends: ${python:Recommends}, logrotate Recommends: ${python:Recommends}, logrotate
Suggests: ${python:Suggests}, ndisc6 Suggests: ${python:Suggests}, ndisc6
Conflicts: re6st-node Conflicts: re6st-node
......
...@@ -13,6 +13,7 @@ Requires: babeld = 1.6.2-nxd1 ...@@ -13,6 +13,7 @@ Requires: babeld = 1.6.2-nxd1
Requires: iproute Requires: iproute
Requires: openssl Requires: openssl
Requires: openvpn >= 2.4 Requires: openvpn >= 2.4
Requires: openvpn < 2.5
Requires: python >= 2.7 Requires: python >= 2.7
Requires: pyOpenSSL >= 0.13 Requires: pyOpenSSL >= 0.13
Requires: python-setuptools Requires: python-setuptools
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment