Commit f3d33177 by Łukasz Nowak

Merge all into slapos.core.

1 parent b3b2ac28
Showing 69 changed files with 78 additions and 373 deletions
*pyc
slapos.core.egg-info
0.1 (unreleased)
================
* Merged slapos.slap, slapos.tool.console, slapos.tool.format,
slapos.tool.grid, slapos.tool.libnetworkcache and slapos.tool.proxy into one
package: slapos.core
include CHANGES.txt
include slapos/format/slapos.xsd
include slapos/slap/slap_recipe_mysqldatabase.py.txt
recursive-include slapos/grid/templates *.in
slapos.core
===========
The core of SlapOS.
from setuptools import setup, find_packages
import glob
import os
version = '0.1'
name = 'slapos.core'
long_description = open("README.txt").read() + "\n" + \
open("CHANGES.txt").read() + "\n"
for f in sorted(glob.glob(os.path.join('slapos', 'README.*.txt'))):
long_description += '\n' + open(f).read() + '\n'
additional_install_requires = []
# Even if argparse is available in python2.7, some python2.7 installations
# do not have it, so checking python version is dangerous
try:
import argparse
except ImportError:
additional_install_requires.append('argparse')
setup(name=name,
version=version,
description="SlapOS core.",
long_description=long_description,
classifiers=[
"Programming Language :: Python",
],
keywords='slapos recipe',
license='GPLv3',
namespace_packages=['slapos'],
packages=find_packages(),
include_package_data=True,
install_requires=[
'Flask', # used by proxy
'lxml', # needed to play with XML trees
'netaddr', # to play safely with IPv6 prefixes
'netifaces', # to fetch information about network devices
'setuptools', # namespaces
'slapos.slap', # used to communicate with master
'supervisor', # slapgrid uses supervisor to manage processes
'xml_marshaller>=0.9.3', # to unmarshall/marshall python objects to/from
# XML
'zc.buildout>=1.5.0', # slapgrid uses buildout as its backend to do the
# job
'zope.interface', # slap library implementes interfaces
] + additional_install_requires,
zip_safe=False, # proxy depends on Flask, which has issues with
# accessing templates
entry_points={
'console_scripts': [
'slapconsole = slapos.console:run',
'slapformat = slapos.format:main',
'slapgrid = slapos.grid.slapgrid:run',
'slapgrid-sr = slapos.grid.slapgrid:runSoftwareRelease',
'slapgrid-cp = slapos.grid.slapgrid:runComputerPartition',
'slapgrid-ur = slapos.grid.slapgrid:runUsageReport',
'slapgrid-supervisorctl = slapos.grid.svcbackend:supervisorctl',
'slapgrid-supervisord = slapos.grid.svcbackend:supervisord',
'slapproxy = slapos.proxy:main',
]
},
)
1.2 (unreleased)
----------------
1.1 (2011/01/04)
----------------
- Update MANIFEST file
1.0 (2011/01/04)
----------------
include CHANGES.txt
include src/slapos/slap/doc/software_instance.xsd
[egg_info]
tag_build = .dev
tag_svn_revision = 1
from setuptools import setup, find_packages
name="slapos.slap"
version='1.2'
def read(name):
return open(name).read()
long_description=(
read('README.txt')
+ '\n' +
read('CHANGES.txt')
)
setup(
name=name,
version=version,
description="slap - Simple Language for Accounting and Provisioning"
" python library",
long_description=long_description,
license="GPLv3",
keywords="slap library",
classifiers=[
],
py_modules = ["slapos.slap.interface.slap"],
namespace_packages = ['slapos'],
packages=find_packages('src'),
include_package_data=True,
package_dir={'':'src'},
install_requires=[
'lxml',
'setuptools',
'xml_marshaller>=0.9.3',
'zope.interface',
],
zip_safe=True,
)
1.0 (unreleased)
----------------
from setuptools import setup, find_packages
import os
name = "slapos.tool.console"
version = '1.1-dev'
def read(*rnames):
return open(os.path.join(os.path.dirname(__file__), *rnames)).read()
long_description=(
read('README.txt')
+ '\n' +
read('CHANGES.txt')
)
setup(
name = name,
version = version,
description = "slapconsole - the slap library console",
long_description=long_description,
license = "GPLv3",
keywords = "vifib console slap",
classifiers=[
],
packages = find_packages('src'),
include_package_data = True,
package_dir = {'':'src'},
namespace_packages = ['slapos', 'slapos.tool'],
install_requires = [
'setuptools', # namespaces
'slapos.slap', # slapgrid uses slap to communicate with vifib
],
zip_safe=False,
entry_points = """
[console_scripts]
slapconsole = %(name)s.console:run
""" % dict(name=name),
)
# See http://peak.telecommunity.com/DevCenter/setuptools#namespace-packages
try:
__import__('pkg_resources').declare_namespace(__name__)
except ImportError:
from pkgutil import extend_path
__path__ = extend_path(__path__, __name__)
# See http://peak.telecommunity.com/DevCenter/setuptools#namespace-packages
try:
__import__('pkg_resources').declare_namespace(__name__)
except ImportError:
from pkgutil import extend_path
__path__ = extend_path(__path__, __name__)
1.1 (unreleased)
----------------
include CHANGES.txt
include slapos.xsd
# -*- coding: utf-8 -*-
from setuptools import setup, find_packages
import os
name = 'slapos.tool.format'
def read(*rnames):
return open(os.path.join(os.path.dirname(__file__), *rnames)).read()
long_description=(
read('README.txt')
+ '\n' +
read('CHANGES.txt')
)
setup(
name = name,
version = '1.1-dev-2',
description = "slapos - partitioning tools for servers",
long_description=long_description,
license = "GPLv3",
keywords = "vifib server partitioning",
include_package_data = True,
packages = find_packages('src'),
package_dir = {'':'src'},
namespace_packages = ['slapos'],
# slapgos use this to create a clean ouput
install_requires = [
'netaddr', # to play safely with IPv6 prefixes
'netifaces', # to fetch information about network devices
'setuptools', # namespace
'slapos.slap', # for posting data to vifib master
'xml_marshaller', # to generate data
],
entry_points = """
[console_scripts]
slapformat = %s:main
""" % name,
)
# See http://peak.telecommunity.com/DevCenter/setuptools#namespace-packages
try:
__import__('pkg_resources').declare_namespace(__name__)
except ImportError:
from pkgutil import extend_path
__path__ = extend_path(__path__, __name__)
# See http://peak.telecommunity.com/DevCenter/setuptools#namespace-packages
try:
__import__('pkg_resources').declare_namespace(__name__)
except ImportError:
from pkgutil import extend_path
__path__ = extend_path(__path__, __name__)
1.0 (unreleased)
----------------
include CHANGES.txt
recursive-include src/slapos/tool/grid/templates *.in
from setuptools import setup, find_packages
import os
name = "slapos.tool.grid"
version = '1.1-dev-2'
def read(*rnames):
return open(os.path.join(os.path.dirname(__file__), *rnames)).read()
long_description=(
read('README.txt')
+ '\n' +
read('CHANGES.txt')
)
additional_install_requires = []
# Even if argparse is available in python2.7, some python2.7 installations
# do not have it, so checking python version is dangerous
try:
import argparse
except ImportError:
additional_install_requires.append('argparse')
setup(
name = name,
version = version,
description = "slapgrid - the vifib client with proposals server cannot"\
" refuse",
long_description=long_description,
license = "GPLv3",
keywords = "vifib server installation",
classifiers=[
],
packages = find_packages('src'),
include_package_data = True,
package_dir = {'':'src'},
namespace_packages = [ 'slapos' ],
install_requires = [
'setuptools', # namespaces
'zc.buildout>=1.5.0', # slapgrid uses buildout as its backend to do the job
'slapos.slap', # slapgrid uses slap to communicate with vifib
'supervisor', # slapgrid uses supervisor to manage processes
] + additional_install_requires,
zip_safe=False,
entry_points = """
[console_scripts]
slapgrid = %(name)s.slapgrid:run
slapgrid-sr = %(name)s.slapgrid:runSoftwareRelease
slapgrid-cp = %(name)s.slapgrid:runComputerPartition
slapgrid-ur = %(name)s.slapgrid:runUsageReport
slapgrid-supervisorctl = %(name)s.svcbackend:supervisorctl
slapgrid-supervisord = %(name)s.svcbackend:supervisord
""" % dict(name=name),
)
# See http://peak.telecommunity.com/DevCenter/setuptools#namespace-packages
try:
__import__('pkg_resources').declare_namespace(__name__)
except ImportError:
from pkgutil import extend_path
__path__ = extend_path(__path__, __name__)
# See http://peak.telecommunity.com/DevCenter/setuptools#namespace-packages
try:
__import__('pkg_resources').declare_namespace(__name__)
except ImportError:
from pkgutil import extend_path
__path__ = extend_path(__path__, __name__)
##############################################################################
#
# Copyright (c) 2010 Vifib SARL and Contributors. All Rights Reserved.
#
# WARNING: This program as such is intended to be used by professional
# programmers who take the whole responsibility of assessing all potential
# consequences resulting from its eventual inadequacies and bugs
# End users who are looking for a ready-to-use solution with commercial
# guarantees and support are strongly adviced to contract a Free Software
# Service Company
#
# This program is Free Software; you can redistribute it and/or
# modify it under the terms of the GNU General Public License
# as published by the Free Software Foundation; either version 3
# of the License, or (at your option) any later version.
#
# This program is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
# GNU General Public License for more details.
#
# You should have received a copy of the GNU General Public License
# along with this program; if not, write to the Free Software
# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
#
##############################################################################
[egg_info]
tag_build = .dev
tag_svn_revision = 1
from setuptools import setup, find_packages
import os
name = "slapos.tool.libnetworkcache"
version = 'O.1'
def read(*rnames):
return open(os.path.join(os.path.dirname(__file__), *rnames)).read()
long_description = (
read('README.txt')
+ '\n' +
read('CHANGES.txt')
)
setup(
name=name,
version=version,
description="libnetworkcache - Client for Networkcache HTTP Server",
long_description=long_description,
license="GPLv3",
keywords="vifib slapos networkcache",
classifiers=[
],
packages=find_packages('src'),
include_package_data=True,
package_dir={'': 'src'},
namespace_packages=['slapos', 'slapos.tool'],
install_requires=[
],
zip_safe=False,
entry_points=""" """,
)
# See http://peak.telecommunity.com/DevCenter/setuptools#namespace-packages
try:
__import__('pkg_resources').declare_namespace(__name__)
except ImportError:
from pkgutil import extend_path
__path__ = extend_path(__path__, __name__)
# See http://peak.telecommunity.com/DevCenter/setuptools#namespace-packages
try:
__import__('pkg_resources').declare_namespace(__name__)
except ImportError:
from pkgutil import extend_path
__path__ = extend_path(__path__, __name__)
1.0 (unreleased)
----------------
from setuptools import setup, find_packages
import os
name = "slapos.tool.proxy"
version = '1.1-dev'
def read(*rnames):
return open(os.path.join(os.path.dirname(__file__), *rnames)).read()
long_description=(
read('README.txt')
+ '\n' +
read('CHANGES.txt')
)
setup(
name = name,
version = version,
description = "slapproxy - the slapos master proxy",
long_description=long_description,
license = "GPLv3",
keywords = "vifib proxy slap",
classifiers=[
],
packages = find_packages('src'),
include_package_data = True,
package_dir = {'':'src'},
namespace_packages = ['slapos', 'slapos.tool'],
install_requires = [
'Flask', # used to create this
'lxml', # needed to play with XML trees
'setuptools', # namespaces
'slapos.slap', # slapgrid uses slap to communicate with vifib
'xml_marshaller', # to unmarshall/marshall python objects to/from XML
],
zip_safe=False,
entry_points = """
[console_scripts]
slapproxy = %(name)s:main
""" % dict(name=name),
)
# See http://peak.telecommunity.com/DevCenter/setuptools#namespace-packages
try:
__import__('pkg_resources').declare_namespace(__name__)
except ImportError:
from pkgutil import extend_path
__path__ = extend_path(__path__, __name__)
# See http://peak.telecommunity.com/DevCenter/setuptools#namespace-packages
try:
__import__('pkg_resources').declare_namespace(__name__)
except ImportError:
from pkgutil import extend_path
__path__ = extend_path(__path__, __name__)
Styling with Markdown is supported
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!