Commit bba54661 by Killian Lufau Committed by Julien Muchembled

obs/re6st: add iproute as build dependency

OpenVPN fails to build on Debian testing because
net-tools is no longer provided by default.
Depends on slapos@67eb9fe4

/reviewed-on !92
1 parent 1be62205
...@@ -6,7 +6,7 @@ pkgrel=1 ...@@ -6,7 +6,7 @@ pkgrel=1
arch=('x86_64' 'i686') arch=('x86_64' 'i686')
license=('GPL') license=('GPL')
depends=('iproute2') depends=('iproute2')
makedepends=('gcc' 'make' 'python2') makedepends=('gcc' 'make' 'python2' 'iproute2')
install='re6stnet.install' install='re6stnet.install'
source=(${pkgname}_${pkgver}.tar.gz) source=(${pkgname}_${pkgver}.tar.gz)
......
...@@ -198,7 +198,7 @@ def deb(task): ...@@ -198,7 +198,7 @@ def deb(task):
d["Version"] = VERSION d["Version"] = VERSION
d["Architecture"] = b["Architecture"] = "any" d["Architecture"] = b["Architecture"] = "any"
d["Build-Depends"] = s["Build-Depends"] = \ d["Build-Depends"] = s["Build-Depends"] = \
"python (>= 2.6), debhelper (>= 8)" "python (>= 2.6), debhelper (>= 8), iproute2 | iproute"
b["Depends"] = "${shlibs:Depends}, iproute2 | iproute" b["Depends"] = "${shlibs:Depends}, iproute2 | iproute"
b["Conflicts"] = b["Provides"] = b["Replaces"] = "re6stnet" b["Conflicts"] = b["Provides"] = b["Replaces"] = "re6stnet"
patched_control = StringIO(str("%s\n%s" % (s, b))) # BBB: cast to str for Python 2.6 patched_control = StringIO(str("%s\n%s" % (s, b))) # BBB: cast to str for Python 2.6
...@@ -229,7 +229,7 @@ s/^(Name:\s*).*/\1%s/ ...@@ -229,7 +229,7 @@ s/^(Name:\s*).*/\1%s/
s/^(Version:\s*).*/\1%s/ s/^(Version:\s*).*/\1%s/
s/^(Release:\s*).*/\11/ s/^(Release:\s*).*/\11/
/^BuildArch:/cAutoReqProv: no\ /^BuildArch:/cAutoReqProv: no\
BuildRequires: gcc-c++, make, python\ BuildRequires: gcc-c++, make, python, iproute\
#!BuildIgnore: rpmlint-Factory\ #!BuildIgnore: rpmlint-Factory\
Source: %%{name}_%%{version}.tar.gz Source: %%{name}_%%{version}.tar.gz
/^Requires:/{ /^Requires:/{
......
Styling with Markdown is supported
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!