Commit 2a74a21d by Jérome Perrin

theia: update python-language-server

 - don't install pycodestyle (just because it complains when indenting
with 2 spaces)
 - add mypy and typeshed (not used, but makes sense to also have)
 - add isort (not used, but makes sense to also have)
 - update pyls and other packages for latest fixes. Get pyls from git to
get fixes for yapf config lookup
parent b777772b
......@@ -23,4 +23,4 @@ md5sum = fc2f20d496911241a0d9001c445d6158
[python-language-server-requirements.txt]
filename = python-language-server-requirements.txt
md5sum = c21a684783b3e746134c3505ce00b757
md5sum = 242c8359be6893725ad2ac8e3c864eb0
autopep8==1.4.2
flake8==3.6.0
future==0.16.0
jedi==0.13.1
appdirs==1.4.3
attrs==18.2.0
black==18.9b0
Click==7.0
future==0.17.1
isort==4.3.4
jedi==0.13.2
mccabe==0.6.1
parso==0.3.1
pluggy==0.8.0
pycodestyle==2.4.0
mypy==0.660
mypy-extensions==0.4.1
parso==0.3.2
pluggy==0.8.1
pydocstyle==3.0.0
pyflakes==2.0.0
python-language-server==0.19.0
pyflakes==2.1.0
python-jsonrpc-server==0.1.2
-e git+https://github.com/palantir/python-language-server@50d03d5931d564e9908292ccfa21dd629ee817ba#egg=python_language_server
rope==0.11.0
six==1.11.0
six==1.12.0
snowballstemmer==1.2.1
yapf==0.24.0
toml==0.10.0
typed-ast==1.2.0
typeshed==0.0.1
yapf==0.25.0
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or sign in to comment