Commit 391b026e by Nicolas Wavrant

slaprunner: downgrade gunicorn to v19.4.5 because of bug in later versions

In gunicorn v19.6 and v19.5, a bug was introduced which deletes socket when nginx worker exits.
In our case, it crashes the slaprunner and prevents it from restarting by slapos.
Let's stick to v19.4.5 until this issue is closed : https://github.com/benoitc/gunicorn/issues/1298
parent 54e29126
......@@ -218,7 +218,7 @@ eggs =
plone.recipe.command
slapos.recipe.build
slapos.toolbox[flask_auth]
Gunicorn
gunicorn
futures
${slapos-cookbook:eggs}
......
......@@ -13,7 +13,7 @@ cns.recipe.symlink = 0.2.3
collective.recipe.environment = 0.2.0
futures = 3.0.5
gitdb = 0.6.4
gunicorn = 19.6.0
gunicorn = 19.4.5
prettytable = 0.7.2
pycurl = 7.43.0
slapos.recipe.template = 2.9
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or sign in to comment