Commit 928ee00d authored by Vincent Pelletier's avatar Vincent Pelletier

component/ffmpeg: Update libvpx to latest release.

0.9.6 fails to build on (at least) gcc 6.3.0, with:
    [CC] nestegg/halloc/src/halloc.c.o
In file included from nestegg/halloc/src/halloc.c:19:0:
nestegg/halloc/src/align.h:33:25: error: conflicting types for 'max_align_t'
 typedef union max_align max_align_t;
                         ^~~~~~~~~~~
In file included from nestegg/halloc/src/../halloc.h:18:0,
                 from nestegg/halloc/src/halloc.c:18:
/usr/lib/gcc/x86_64-linux-gnu/6/include/stddef.h:429:3: note: previous declaration of 'max_align_t' was here
 } max_align_t;
   ^~~~~~~~~~~
Makefile:104: recipe for target 'nestegg/halloc/src/halloc.c.o' failed

Also, add --disable-static configure option.
Also, reindent configure options.
parent 9489ee93
......@@ -49,10 +49,11 @@ url = http://www.tortall.net/projects/yasm/releases/yasm-1.1.0.tar.gz
[libvpx]
recipe = slapos.recipe.cmmi
url = http://webm.googlecode.com/files/libvpx-v0.9.6.tar.bz2
md5sum = 383f3f07a76099682abb43f79b692b72
url = http://storage.googleapis.com/downloads.webmproject.org/releases/webm/libvpx-1.6.1.tar.bz2
md5sum = a19518c8111fa93bdabdd85259162611
configure-options =
--enable-shared
--enable-shared
--disable-static
environment =
PATH=${yasm:location}/bin:%(PATH)s
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment