Commit 96ca850f by Kazuhiko Shiozaki

fixup! add firewalld component

1 parent 9dae9737
[buildout]
parts =
parts =
firewalld-patch
extends =
extends =
../pkgconfig/buildout.cfg
../autoconf/buildout.cfg
../automake/buildout.cfg
......@@ -24,10 +24,10 @@ recipe = slapos.recipe.cmmi
url = https://github.com/t-woerner/firewalld/archive/v0.3.14.2.tar.gz
md5sum = b8f81b536ede502721f69300d374447b
python-egg = ${buildout:parts-directory}/${:_buildout_section_name_}/lib/python2.7/site-packages
configure-command =
pre-configure =
sed -i -E 's,(^SUBDIRS *=.*) doc(\b.*),\1\2,' Makefile.am
aclocal -I${pkgconfig:location}/share/aclocal -I${gettext:location}/share/aclocal -I${libtool:location}/share/aclocal
./autogen.sh
sed -i "s#SUBDIRS = config doc po shell-completion src#SUBDIRS = config po shell-completion src#" Makefile
environment =
PKG_CONFIG_PATH=${glib:location}/lib/pkgconfig
......@@ -49,7 +49,7 @@ python-egg = ${buildout:parts-directory}/${:_buildout_section_name_}/lib/python2
environment =
PKG_CONFIG_PATH=${dbus:location}/lib/pkgconfig:${dbus-glib:location}/lib/pkgconfig:${glib:location}/lib/pkgconfig
PATH=${pkgconfig:location}/bin:%(PATH)s
DBUS_CFLAGS=-I${dbus:location}/include/dbus-1.0 -I${dbus:location}/lib/dbus-1.0/include
DBUS_CFLAGS=-I${dbus:location}/include/dbus-1.0 -I${dbus:location}/lib/dbus-1.0/include
DBUS_LIBS=-L${dbus:location}/lib -ldbus-1
DBUS_GLIB_CFLAGS=-I${dbus-glib:location}/include/dbus-1.0
DBUS_GLIB_LIBS=-L${dbus-glib:location}/lib -ldbus-glib-1
......@@ -62,11 +62,11 @@ environment =
[gobject-introspection]
recipe = slapos.recipe.cmmi
url = https://github.com/GNOME/gobject-introspection/archive/GOBJECT_INTROSPECTION_1_45_2.tar.gz
configure-command =
pre-configure =
libtoolize -c -f
aclocal -I${pkgconfig:location}/share/aclocal -I${gettext:location}/share/aclocal -I${libtool:location}/share/aclocal
./autogen.sh
configure-options =
configure-options =
--disable-static
environment =
......@@ -86,12 +86,10 @@ environment =
recipe = slapos.recipe.cmmi
url = http://ftp.gnome.org/pub/GNOME/sources/pygobject/3.10/pygobject-3.10.2.tar.xz
python-egg = ${buildout:parts-directory}/${:_buildout_section_name_}/lib/python2.7/site-packages
# md5sum =
configure-command =
md5sum = f311155be8510df6ad8e4edf1cb463d4
pre-configure =
sed -i 's#/usr/local#${gobject-introspection:location}#g' ${gobject-introspection:location}/lib/pkgconfig/gobject-introspection-1.0.pc
./configure
configure-options =
--prefix=${buildout:parts-directory}/${:_buildout_section_name_}
configure-options =
--disable-static
--disable-cairo
--with-python=${python2.7:location}/bin/python2.7
......@@ -120,7 +118,7 @@ md5sum = 893752ba2e93a1e96334dfee19f884ad
[firewalld-patch]
recipe = plone.recipe.command
python = ${buildout:directory}/bin/${firewalld-eggs:interpreter}
command =
command =
sed -i 's#/usr/bin/python -Es#${:python}#' ${firewalld:location}/bin/firewall-cmd
sed -i 's#/usr/bin/python -Es#${:python}#' ${firewalld:location}/sbin/firewalld
sed -i 's#DefaultZone=public#DefaultZone=trusted#' ${firewalld:location}/etc/firewalld/firewalld.conf
......@@ -137,7 +135,7 @@ update-command = ${:command}
[firewalld-eggs]
recipe = zc.recipe.egg:scripts
interpreter = python.eggs
eggs =
eggs =
decorator
six
${python-slip-egg:eggs}
......
......@@ -119,6 +119,7 @@ cliff = 1.15.0
cmd2 = 0.6.8
collective.recipe.template = 1.11
cryptography = 1.0.2
decorator = 4.0.4
idna = 2.0
inotifyx = 0.2.2
itsdangerous = 0.24
......@@ -126,6 +127,7 @@ lxml = 3.4.4
meld3 = 1.0.2
netaddr = 0.7.18
pbr = 1.8.1
plone.recipe.command = 1.1
prettytable = 0.7.2
psutil = 3.2.2
pyOpenSSL = 0.15.1
......@@ -147,7 +149,7 @@ unicodecsv = 0.14.1
xml-marshaller = 0.9.7
# Required by:
# slapos.core==1.3.11
# slapos.core==1.3.12
Flask = 0.10.1
# Required by:
......@@ -180,7 +182,7 @@ jsonschema = 2.5.1
lock-file = 2.0
# Required by:
# slapos.core==1.3.11
# slapos.core==1.3.12
netifaces = 0.10.4
# Required by:
......@@ -188,15 +190,15 @@ netifaces = 0.10.4
pycparser = 2.14
# Required by:
# slapos.core==1.3.11
# slapos.core==1.3.12
supervisor = 3.1.3
# Required by:
# slapos.core==1.3.11
# slapos.core==1.3.12
uritemplate = 0.6
# Required by:
# slapos.core==1.3.11
# slapos.core==1.3.12
zope.interface = 4.1.3
[networkcache]
......
Styling with Markdown is supported
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!