• Kirill Smelkov's avatar
    fixup! v↑ zodbtools (0.0.0.dev4) · 6fc10621
    Kirill Smelkov authored
    9b5d8262 (v↑ zodbtools (0.0.0.dev4)) added zodburi and in turn ZEO
    dependency to neoppod/software-common.cfg because zodburi currently
    non-optionally requires ZEO.
    
    However I forgot to notice that if we always pin ZEO to 4.x it will
    require `transaction < 2` and this will break neoppod/software-zodb5.cfg
    which requires ZODB 5.x and in turn `transaction >= 2`:
    
    	Installing neoppod.
    	Version and requirements information containing transaction:
    	  [versions] constraint on transaction: 2.1.2
    	  Requirement of ZODB==5.3.0: transaction>=2.0.3
    	  Requirement of transaction>=2.0.3: zope.interface
    	  Requirement of ZEO: transaction<2.0.0
    	While:
    	  Installing neoppod.
    	Error: The requirement ('transaction<2.0.0') is not allowed by your [versions] constraint (2.1.2)
    
    We already have ZODB = 4.x in software-common.cfg and software-zodb5.cfg
    overrides it to ZODB = 5.x, but ZEO was left not-overwritten and this
    way there becomes conflicting requirement on transaction.
    
    Fix it by also overriding ZEO in software-zodb5.cfg
    
    /reported-and-reviewed-by @jm
    /reported-on !242 (comment 49754)
    6fc10621
Name
Last commit
Last update
component Loading commit data...
slapos Loading commit data...
software Loading commit data...
stack Loading commit data...
.gitignore Loading commit data...
CHANGES.rst Loading commit data...
MANIFEST.in Loading commit data...
README.rst Loading commit data...
README.software.rst Loading commit data...
schema.json Loading commit data...
setup.py Loading commit data...
sla.schema.json Loading commit data...
update-hash Loading commit data...
validate-schema Loading commit data...