Commit 50a245c7 authored by fxa's avatar fxa

corrected file list and readme

parent 6f190e92
......@@ -15,7 +15,7 @@ Requirements
You can use uritemplate.js in any modern browsers (Tested even with IE8 in IE7-Mode), see file demo.html.
But you can also use it with node:
npm install git://www.github.com/fxa/uritemplate-js.git
npm install uritemplate
var
UriTemplate = require('uritemplate'),
......@@ -35,7 +35,6 @@ Run the tests with
Comming soon
------------
* npm support for npm install
* A new method extract(uri), which tries to extract the variables from a given uri
License
......
......@@ -6,7 +6,22 @@
"author" : "Franz Antesberger",
"contributors" : [],
"dependencies" : [],
"repository" : {"type": "git", "url": "https://github.com/fxa/uritemplate-js.git"},
"main" : "src/uritemplate.js",
"version" : "0.1.0"
"licenses": [{
"type": "MIT",
"url": "http://www.opensource.org/licenses/mit-license.php"
}],
"files": [
"src/uritemplate.js",
"demo.html",
"test.js",
"README.md",
".gitmodules",
"uritemplate-test/extended-tests.json",
"uritemplate-test/negative-tests.json",
"uritemplate-test/README.md",
"uritemplate-test/spec-examples-by-sections.json",
"uritemplate-test/spec-examples.json"
],
"version" : "0.1.1"
}
\ No newline at end of file
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment