Commit c96daa2f authored by Kirill Smelkov's avatar Kirill Smelkov

tox/ZODB3: Limit ZConfig < 3.2.0

With ZConfig==3.2.0 (released 2017-06-22) ZEO started to get file names
as unicode, which eventually breaks on assert in ZODB3.FileStorage code:

    Traceback (most recent call last):
      File "/home/kirr/src/wendelin/r/work/venv/local/lib/python2.7/site-packages/ZEO/tests/zeoserver.py", line 215, in <module>
        main()
      File "/home/kirr/src/wendelin/r/work/venv/local/lib/python2.7/site-packages/ZEO/tests/zeoserver.py", line 188, in main
        server = ZEO.runzeo.create_server({"1": storage}, zo)
      File "/home/kirr/src/wendelin/r/work/venv/local/lib/python2.7/site-packages/ZEO/runzeo.py", line 366, in create_server
        auth_realm = options.auth_realm,
      File "/home/kirr/src/wendelin/r/work/venv/local/lib/python2.7/site-packages/ZEO/StorageServer.py", line 890, in __init__
        self._setup_invq(name, storage)
      File "/home/kirr/src/wendelin/r/work/venv/local/lib/python2.7/site-packages/ZEO/StorageServer.py", line 928, in _setup_invq
        self.invq[name] = list(lastInvalidations(self.invq_bound))
      File "/home/kirr/src/wendelin/r/work/venv/local/lib/python2.7/site-packages/ZODB/FileStorage/FileStorage.py", line 1238, in lastInvalidations
        for trans in FileIterator(self._file_name, pos=pos)]
      File "/home/kirr/src/wendelin/r/work/venv/local/lib/python2.7/site-packages/ZODB/FileStorage/FileStorage.py", line 1640, in __init__
        assert isinstance(filename, str), `filename`
    AssertionError: u'/home/kirr/src/wendelin/r/work/wendelin.core/Data.fs'

-> So for ZODB3 pin ZConfig to ZConfig <3.2.0 which is known to work with ZODB3.
parent e9d61a89
......@@ -12,6 +12,9 @@ deps =
# latest ZODB from 3 series
ZODB3: ZODB3 >=3.10, <3.11dev
ZODB3: transaction <2.0dev
# ZConfig 3.2.0 passes filename to ZEO config as unicode which eventualy breaks in FileStorage:
# https://github.com/zopefoundation/ZODB/blob/3.10.7-4-gb8d7a8567/src/ZODB/FileStorage/FileStorage.py#L1640
ZODB3: ZConfig <3.2.0
# latest current ZODB _4_
ZODB4: ZODB >=4.0, <5.0dev
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment