Skip to content
Projects
Groups
Snippets
Help
Loading...
Help
Support
Keyboard shortcuts
?
Submit feedback
Contribute to GitLab
Sign in / Register
Toggle navigation
F
fastkml
Project overview
Project overview
Details
Activity
Releases
Repository
Repository
Files
Commits
Branches
Tags
Contributors
Graph
Compare
Issues
0
Issues
0
List
Boards
Labels
Milestones
Merge Requests
0
Merge Requests
0
Analytics
Analytics
Repository
Value Stream
Wiki
Wiki
Snippets
Snippets
Members
Members
Collapse sidebar
Close sidebar
Activity
Graph
Create a new issue
Commits
Issue Boards
Open sidebar
Aurélien Vermylen
fastkml
Commits
a5768e5c
Commit
a5768e5c
authored
Jul 02, 2015
by
Christian Ledermann
Browse files
Options
Browse Files
Download
Email Patches
Plain Diff
yapf and autopep8 changes, add codecov to travis, remove continuous deploy for now
parent
fd84af85
Changes
3
Expand all
Show whitespace changes
Inline
Side-by-side
Showing
3 changed files
with
152 additions
and
145 deletions
+152
-145
.travis.yml
.travis.yml
+6
-9
fastkml/geometry.py
fastkml/geometry.py
+1
-1
fastkml/test_main.py
fastkml/test_main.py
+145
-135
No files found.
.travis.yml
View file @
a5768e5c
...
@@ -8,6 +8,8 @@ python:
...
@@ -8,6 +8,8 @@ python:
env
:
env
:
-
LXML=true
-
LXML=true
-
LXML=false
-
LXML=false
before_install
:
pip install codecov
install
:
install
:
-
pip install -r requirements.txt
-
pip install -r requirements.txt
-
if $LXML ==
true
; then pip install lxml; fi
-
if $LXML ==
true
; then pip install lxml; fi
...
@@ -15,16 +17,11 @@ install:
...
@@ -15,16 +17,11 @@ install:
script
:
script
:
-
coverage run --source=fastkml setup.py test
-
coverage run --source=fastkml setup.py test
-
if [[ $TRAVIS_PYTHON_VERSION != 3.2 ]]; then cd docs && make html; fi
-
if [[ $TRAVIS_PYTHON_VERSION != 3.2 ]]; then cd docs && make html; fi
after_success
:
coveralls
after_success
:
coveralls
codecov
notifications
:
notifications
:
email
:
email
:
-
christian.ledermann@gmail.com
-
christian.ledermann@gmail.com
-
IanLee1521@gmail.com
-
IanLee1521@gmail.com
deploy
:
provider
:
pypi
user
:
password
:
secure
:
distributions
:
"
sdist
bdist_wheel"
on
:
tags
:
true
fastkml/geometry.py
View file @
a5768e5c
...
@@ -130,9 +130,9 @@ class Geometry(_BaseObject):
...
@@ -130,9 +130,9 @@ class Geometry(_BaseObject):
def
_set_altitude_mode
(
self
,
element
):
def
_set_altitude_mode
(
self
,
element
):
if
self
.
altitude_mode
:
if
self
.
altitude_mode
:
# XXX add 'relativeToSeaFloor', 'clampToSeaFloor',
assert
(
self
.
altitude_mode
in
[
assert
(
self
.
altitude_mode
in
[
'clampToGround'
,
'clampToGround'
,
# 'relativeToSeaFloor', 'clampToSeaFloor',
'relativeToGround'
,
'absolute'
'relativeToGround'
,
'absolute'
])
])
if
self
.
altitude_mode
!=
'clampToGround'
:
if
self
.
altitude_mode
!=
'clampToGround'
:
...
...
fastkml/test_main.py
View file @
a5768e5c
This diff is collapsed.
Click to expand it.
Write
Preview
Markdown
is supported
0%
Try again
or
attach a new file
Attach a file
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Cancel
Please
register
or
sign in
to comment