Skip to content
Projects
Groups
Snippets
Help
Loading...
Help
Support
Keyboard shortcuts
?
Submit feedback
Contribute to GitLab
Sign in / Register
Toggle navigation
F
fastkml
Project overview
Project overview
Details
Activity
Releases
Repository
Repository
Files
Commits
Branches
Tags
Contributors
Graph
Compare
Issues
0
Issues
0
List
Boards
Labels
Milestones
Merge Requests
0
Merge Requests
0
Analytics
Analytics
Repository
Value Stream
Wiki
Wiki
Snippets
Snippets
Members
Members
Collapse sidebar
Close sidebar
Activity
Graph
Create a new issue
Commits
Issue Boards
Open sidebar
Aurélien Vermylen
fastkml
Commits
614bd4cb
Commit
614bd4cb
authored
Nov 02, 2014
by
Christian Ledermann
Browse files
Options
Browse Files
Download
Plain Diff
Merge pull request #24 from cleder/issue-23
Use pkg_resources to get the version from setup.py
parents
f98d75c3
df3ada34
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
with
6 additions
and
4 deletions
+6
-4
fastkml/__init__.py
fastkml/__init__.py
+5
-1
setup.py
setup.py
+1
-3
No files found.
fastkml/__init__.py
View file @
614bd4cb
...
...
@@ -25,6 +25,7 @@ google maps rather than to give you all functionality that KML on google earth
provides.
"""
from
pkg_resources
import
get_distribution
,
DistributionNotFound
from
.kml
import
KML
,
Document
,
Folder
,
Placemark
from
.kml
import
TimeSpan
,
TimeStamp
...
...
@@ -37,7 +38,10 @@ from .styles import LabelStyle, BalloonStyle
from
.atom
import
Link
,
Author
,
Contributor
__version__
=
'0.10.dev'
try
:
__version__
=
get_distribution
(
'fastkml'
).
version
except
DistributionNotFound
:
__version__
=
'dev'
__all__
=
[
'KML'
,
'Document'
,
'Folder'
,
'Placemark'
,
...
...
setup.py
View file @
614bd4cb
...
...
@@ -3,8 +3,6 @@ from setuptools.command.test import test as TestCommand
import
sys
import
os
import
fastkml
class
PyTest
(
TestCommand
):
def
finalize_options
(
self
):
...
...
@@ -21,7 +19,7 @@ class PyTest(TestCommand):
setup
(
name
=
'fastkml'
,
version
=
fastkml
.
__version__
,
version
=
'0.10.dev'
,
description
=
"Fast KML processing in python"
,
long_description
=
(
open
(
"README.rst"
).
read
()
+
"
\
n
"
+
...
...
Write
Preview
Markdown
is supported
0%
Try again
or
attach a new file
Attach a file
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Cancel
Please
register
or
sign in
to comment