Skip to content
Projects
Groups
Snippets
Help
Loading...
Help
Support
Keyboard shortcuts
?
Submit feedback
Contribute to GitLab
Sign in / Register
Toggle navigation
F
fastkml
Project overview
Project overview
Details
Activity
Releases
Repository
Repository
Files
Commits
Branches
Tags
Contributors
Graph
Compare
Issues
0
Issues
0
List
Boards
Labels
Milestones
Merge Requests
0
Merge Requests
0
Analytics
Analytics
Repository
Value Stream
Wiki
Wiki
Snippets
Snippets
Members
Members
Collapse sidebar
Close sidebar
Activity
Graph
Create a new issue
Commits
Issue Boards
Open sidebar
Aurélien Vermylen
fastkml
Commits
cbd1310d
Commit
cbd1310d
authored
Jul 27, 2012
by
Christian Ledermann
Browse files
Options
Browse Files
Download
Email Patches
Plain Diff
prepare 0.2 release
parent
fa51c0bb
Changes
4
Hide whitespace changes
Inline
Side-by-side
Showing
4 changed files
with
22 additions
and
18 deletions
+22
-18
README.rst
README.rst
+9
-8
docs/HISTORY.txt
docs/HISTORY.txt
+8
-0
fastkml/geometry.py
fastkml/geometry.py
+2
-7
setup.py
setup.py
+3
-3
No files found.
README.rst
View file @
cbd1310d
...
...
@@ -9,9 +9,8 @@ a subset of KML and is aimed at documents that can be read from multiple
clients such as openlayers and google maps rather than to give you all
functionality that KML on google earth provides.
Geometries are handled as shapely objects. This is a restriction that I
can live with and you will seldom find KML files that implement more
complex geometries.
Geometries are handled as pygeoif or shapely (if installed) objects.
Limitations
...
...
@@ -21,7 +20,9 @@ Geometries are limited to the geometry and multigeometry types shapely
provides (Point, LineString, Polygon, MultiPoint, MultiLineString,
MultiPolygon and LinearRing). While KML allows for more abstract
MultiGeometries consisting of a combination of Points, LineStrings
and LinearRings, this is not supported in fastkml
and LinearRings, this is not supported in fastkml.
This is a restriction that I can live with and you will rarely find KML
files that implement more complex geometries.
Usage
=====
...
...
@@ -33,8 +34,8 @@ quick overview:
Build a KML from scratch:
--------------------------
Example how to build a simple KML file
:
::
Example how to build a simple KML file
>>> from fastkml import kml
>>> from shapely.geometry import Point, LineString, Polygon
>>> k = kml.KML()
...
...
@@ -100,8 +101,8 @@ Example how to build a simple KML file:
Read a KML file
----------------
You can create a KML object by reading a KML file
:
::
You can create a KML object by reading a KML file
>>> from fastkml import kml
>>> doc = """<?xml version="1.0" encoding="UTF-8"?>
... <kml xmlns="http://www.opengis.net/kml/2.2">
...
...
docs/HISTORY.txt
View file @
cbd1310d
Changelog
=========
0.2 (2012/07/27)
-----------------
- remove dependency on shapely
- add more functionality
0.1.1 (2012/06/29)
------------------
...
...
fastkml/geometry.py
View file @
cbd1310d
...
...
@@ -15,13 +15,8 @@
# MA 02110-1301, USA.
"""
This should be rewritten to implement a more general and less
Shapely dependent way to represent geometries
https://gist.github.com/2217756
I wonder if the "geojson" package fits
the purpose or it's rather better to implement to protocol from scratch.
Import the geometries from shapely if it is installed
or otherwise from Pygeoif
"""
try
:
...
...
setup.py
View file @
cbd1310d
from
setuptools
import
setup
,
find_packages
import
sys
,
os
version
=
'0.
1.1
'
version
=
'0.
2
'
setup
(
name
=
'fastkml'
,
version
=
version
,
description
=
"Fast KML processing
for
python"
,
description
=
"Fast KML processing
in
python"
,
long_description
=
open
(
"README.rst"
).
read
()
+
"
\
n
"
+
open
(
os
.
path
.
join
(
"docs"
,
"HISTORY.txt"
)).
read
(),
...
...
@@ -14,7 +14,7 @@ setup(name='fastkml',
"Programming Language :: Python"
,
'Intended Audience :: Developers'
,
'License :: OSI Approved :: GNU General Public License (GPL)'
,
'Development Status ::
3 - Alph
a'
,
'Development Status ::
4 - Bet
a'
,
'Operating System :: OS Independent'
,
],
# Get strings from http://pypi.python.org/pypi?%3Aaction=list_classifiers
keywords
=
'GIS KML Google Maps OpenLayers'
,
...
...
Write
Preview
Markdown
is supported
0%
Try again
or
attach a new file
Attach a file
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Cancel
Please
register
or
sign in
to comment