Commit 57c90ac6 authored by Alain Takoudjou's avatar Alain Takoudjou

playbook: upgrade slapcache tools if needed before launch upgrader playbook

Some servers failed to run upgrader because slapos.libnetworkcache was old and not compatible anymore. So playbook couldn't be downloaded.
We check if slapos.libnetworkcache and slapcache need to be upgraded before run upgrader role.

/reviewed-on nexedi/slapos.package!65
parent 9a3eb09a
# easy_install module for ansible version on debian 8 cannot upgrade package
- name: Install/Upgrade latest slapos.libnetworkcache
shell: easy_install --upgrade slapos.libnetworkcache
- name: Instal/Upgrade latest slapcache
shell: easy_install --upgrade slapcache
---
dependencies:
- { role: slapcache }
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment