• Kirill Smelkov's avatar
    Drop support for ZODB3 · c59a54ca
    Kirill Smelkov authored
    Nexedi stack is dropping support for that old ZODB version - see e.g.
    
    - nexedi/slapos@70d05199
    - nexedi/neoppod@3a8f6f03
    - nexedi/wendelin.core@0802da2b
    
    Regarding test/gen_testdata.py: even though ZODB4 uses zodbpickle, and
    so should be able to load pickles encoded with protocol 3 even on
    python2, in practice it does not work so well: ZODB4 tests fail if I set
    
        --- a/src/ZODB/_compat.py
        +++ b/src/ZODB/_compat.py
        @@ -34,7 +34,7 @@
             HIGHEST_PROTOCOL = cPickle.HIGHEST_PROTOCOL
             IMPORT_MAPPING = {}
             NAME_MAPPING = {}
        -    _protocol = 1
        +    _protocol = 3
             FILESTORAGE_MAGIC = b"FS21"
         else:
             # Python 3.x: can't use stdlib's pickle because
    
    -> so continue to preserve protocol < 3 when generating the test
    database for compatibility - now with ZODB4/py2.
    
    /reviewed-by @jerome
    /reviewed-on nexedi/zodbtools!18
    c59a54ca
Name
Last commit
Last update
zodbtools Loading commit data...
.gitignore Loading commit data...
.nxdtest Loading commit data...
CHANGELOG.rst Loading commit data...
COPYING Loading commit data...
LICENSE-ZPL.txt Loading commit data...
MANIFEST.in Loading commit data...
README.rst Loading commit data...
setup.py Loading commit data...
tox.ini Loading commit data...