• Jérome Perrin's avatar
    software.cfg: update slapos to 1.0.244 · f5d74660
    Jérome Perrin authored
    We have a test suite OfficeJS.Appstore.UnitTest-Master failing to
    run since a few days with an error like this:
    
         $ /srv/slapgrid/slappart3/t/cag/i/5/bin/runTestSuite --help
         Traceback (most recent call last):
           File "../bin/runTestSuite", line 298, in <module>
             import Products.ERP5Type.tests.runTestSuite
           File "../parts/erp5/product/ERP5Type/__init__.py", line 86, in <module>
             from Products.ERP5Type.Utils import initializeProduct, updateGlobals
           File "../parts/erp5/product/ERP5Type/Utils.py", line 32, in <module>
             from past.builtins import cmp
         ImportError: No module named past.builtins
    
    This is because with erp5 commit a17bb91030 (py2/py3: Make Products
    code compatible with both python2 and python3., 2022-04-13) we have
    a new dependency. That dependency is provided by the new SlapOS
    software release, so ERP5 has a minimal requirement for this new
    SlapOS software release.
    
    These changes are about updating SlapOS software release. The old
    version pins are no longer needed here, because SlapOS software
    release provides them. SlapOS now comes with a newer version of Zope2
    and also with their own patches to Zope2, so we use += to apply this
    patch on top of SlapOS patches
    f5d74660