Commit 065564b0 authored by Jérome Perrin's avatar Jérome Perrin

tests: ignore new warning from setuptools 42

setuptools 42.0.0 prints a warning:

   WARNING: The easy_install command is deprecated and will be removed in a future version

use a test normalizer to ignore this warning in doctest.
parent b6a17ed6
......@@ -26,6 +26,7 @@
##############################################################################
from __future__ import print_function
import doctest
import re
import unittest
from zc.buildout import testing
from zope.testing import renormalizing
......@@ -37,6 +38,11 @@ def setUp(test):
run_buildout = lambda: print(system(buildout), end='')
))(**test.globs)
normalize_setuptools_42 = re.compile(
'WARNING: The easy_install command is deprecated and will be removed in a future version\\.\n'), ''
def test_suite():
return unittest.TestSuite([
doctest.DocFileSuite(
......@@ -46,6 +52,7 @@ def test_suite():
checker=renormalizing.RENormalizing((
testing.normalize_path,
testing.not_found,
normalize_setuptools_42,
)),
) for filename in [
'README.txt',
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment